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Contact Us!

Pro*C/C++ Precompiler Getting Started, Release 8.1.6 for Windows

Part No.  A73023-01

This document describes how to contact Oracle Corporation if you have issues with 
the documentation or software.
 

Read the section... If you...

How to Contact Oracle Technical Publications on page viii Have issues with Documentation

How to Contact Oracle Support Services on page ix Have issues with Software

Resources for Oracle Partners and Developers on page xiii Want to join an Oracle partner or application 
developer program
vii



How to Contact Oracle Technical Publications
Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this 
publication. Your input is an important part of the information used for revision.

■ Did you find any errors?
■ Is the information clearly presented?
■ Do you need more information? If so, where?
■ Are the examples correct? Do you need more examples?
■ What features did you like most about this guide?
■ Do you have suggestions for improvement? Please indicate the chapter, section, and page 

number (if available). 

You can send comments regarding documentation in the following ways:

■ Electronic mail - ntdoc@us.oracle.com
■ FAX - (650) 506-7370   Attn:  Oracle Windows Platforms Server Documentation
■ Postal service:

Oracle Corporation 
Windows Platforms Server Documentation Manager
500 Oracle Parkway, MS 1OP8,
Redwood Shores, CA  94065
USA

If you would like a reply, please provide your name, address, and telephone number.
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 How to Contact Oracle Support Services
Please copy this form and distribute within your organization as necessary.

Oracle Support Services can be reached at the following telephone numbers and Web sites. The hours 
of business are detailed in your support contract and the Oracle Customer Support Guide in your kit.

Please complete the following checklist before you call. If you have this information ready, your call 
can be processed much quicker.

❏ Your CPU Support Identification Number (CSI Number) if applicable.

❏ The hardware name on which your application is running. 

Oracle Support 
Services In... Call...

United States of 
America

+ (650) 506-1500 for customers with support contracts.

+ (650) 506-5577 to obtain a support contract.

Europe +44 1344 860 160 or the local support center in your country.

All other 
locations

The telephone number for your country listed at the following Web site:

http://www.oracle.com/support/contact_us/sup_hot_
phone.html

Oracle Support Services telephone numbers are also listed in the Oracle 
Customer Support Guide in your kit.
ix



❏ The operating system name and release number on which your application is 
running.

■ To verify the operating system version on Windows NT, enter the following 
at the MS-DOS command prompt:

C:\> WINMSD

The Windows NT Diagnostics dialog box displays the operating system and 
Service Pack version.

❏ The release numbers of the Oracle Server and associated products involved in 
the current problem. For example, Oracle8i Enterprise Edition release 8.1.6.0.0 
and Oracle Enterprise Manager release 2.1.0.0.0.

■ To verify the release number of the Oracle Server, connect to the database 
using a tool such as SQL*Plus. The release number is displayed. For 
example:

Connected to: 
Oracle8i Enterprise Edition Release 8.1.6.0.0 - Production 
With the Partitioning and Java options 
PL/SQL Release 8.1.6.0.0 - Production 

❏ The third-party software version you are using.

■ To verify an application version, from the application’s Help menu, select 
About... 
x



❏ The exact error codes and messages. Please write these down as they occur. 
They are critical in helping Oracle Support Services to quickly resolve your 
problem. Note whether there were no errors reported.

❏ A description of the issue, including:

■ What happened? For example, the command used and its result. 
 

■ When did it happen? For example, during peak system load, or after a 
certain command, or after an operating system upgrade. In addition, what 
was happening when the problem occurred? 

■ Where did it happen? For example, on a particular system, or within a 
certain procedure or table.
xi



■ What is the extent of the problem? For example, production system 
unavailable, or moderate impact but increasing with time, or minimal 
impact and stable. 

■ Did the problem affect one user, several users, or all users? 

■ Has anything changed? For example, if this is an operation that used to 
work and now fails, what is different? Can you undo any recent changes, to 
verify whether they are relevant to the issue? 

■ Can the problem be reproduced? This is a critical question for support 
analysts. For example, did the problem recur on the same system, under the 
same circumstances? Can the problem be reproduced on another system? 
Additionally:

■ Does installing a software component fail on all client machines, or just 
one? 

■ Do all clients fail to connect to the server, or just one?

■ If you are able to restart the server or database, does restarting the database 
or rebooting the server or client machine (if applicable) make a difference?

❏ Keep copies of the Oracle alert log, any trace files, core dumps, and redo log 
files recorded at or near the time of the incident. Oracle Support Services may 
need these to further investigate your problem. 

To help analyze problems: 

■ Archive or delete old alert logs. When the database is started without an 
alert log, a new one is created. In some cases, if you force the problem to 
recur with a new alert log, the timestamps for the recorded events may 
indicate which events are relevant. 
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■ Archive or delete old trace files. To check whether the file was modified, 
right-click and select Properties. The Properties dialog box displays the 
modification date.

■ Check the operating system error logs, especially the System log and 
Application log. These files are relevant to the Oracle Server. To view these 
files, from the Start menu, choose Programs > Administrative Tools > Event 
Viewer, and choose System or Application from the Log main menu. 

Resources for Oracle Partners and Developers
This section provides information on partner programs and resources for Oracle database administra-
tors and application developers.

Information Source Description

Oracle Corporation Home Page

http://www.oracle.com

This Web site is the starting point for general information on 
Oracle Corporation.

Alliance Online

http://alliance.oracle.com

Oracle provides leading-edge technology, education, and 
technical support that enables you to effectively integrate 
Oracle into your business. By joining the Oracle Partner 
Program, you demonstrate to customers that you are 
committed to delivering innovative Oracle-based solutions 
and services.

The greater your commitment to Oracle, the more we can 
help you grow your business. It’s that simple. The value you 
derive is associated directly with your level of commitment.

Oracle Education

http://education.oracle.com/

Customers come to Oracle Education with a variety of 
needs. You may require a complete curriculum based on 
your job role to enable you to implement new technology. Or 
you may seek an understanding of technology related to 
your key area of responsibility to help you meet technical 
challenges. You may be looking for self-paced training that 
can be used as an ongoing resource for reference and 
hands-on practice. Or, you may be interested in an overview 
of a new product upgrade. Whatever your training need, 
Oracle Education has the solution. 
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Oracle Technology Network

http://technet.oracle.com/

The Oracle Technology Network is your definitive source for 
Oracle technical information for developing for the Internet 
platform. You will be part of an online community with 
access to free software, Oracle Technology 
Network-sponsored Internet developer conferences, and 
discussion groups on up-to-date Oracle technology. 
Membership is free.

Oracle Store

http://oraclestore.oracle.com/

This is Oracle’s online shopping center. Come to this site to 
find special deals on Oracle software, documentation, 
publications, computer-based training products, and much 
more.

Oracle Support Services’ Support Web Center

http://www.oracle.com/support/

Oracle Support Services offers a range of programs so you 
can select the support services you need and access them in 
the way you prefer: by telephone, electronically, or face to 
face. These award-winning programs help you maintain 
your investment in Oracle technology and expertise.

Here are some of the resources available in the Support Web 
Center:

OracleMetaLink

http://www.oracle.com/support/
elec_sup/index.html

OracleMetaLink is Oracle Support Services' premier Web 
support service. It is available to Oraclemetals customers 
(Gold, Silver, Bronze), 24 hours a day, seven days a 
week.

OracleLifecycle

http://www.oracle.com/support/
sup_serv/lifecycle/index.html

OracleLifecycle is designed to deliver customized, 
industry-focused, full life-cycle support solutions that 
enable industry leaders to use Oracle technology to 
make smart business decisions, achieve operational 
excellence, and succeed in their markets.

ExpertONLINE

http://www.oracle.com/support/
sup_serv/online/index.html

Oracle Support Services has launched a new line of 
services called ExpertONLINE. These services provide 
online database administration for companies looking 
to supplement their existing DBA staff or fill a DBA 
role. Services range from ExpertDETECT, a monitoring, 
diagnostic, and recommendation service, to ExpertDBA, 
a full online database administration service.

Virtual Support Analyst (VSA)

http://www.oracle.com/support/
sup_serv/vsa_start.html

VSA is Oracle's Internet e-mail service; it is available to 
U.S. customers with an Oraclemetals support agreement. 
With VSA, you can initiate a request for assistance 
through e-mail, bypassing the queues you may 
encounter when using telephone support. VSA also 
enables you to access Oracle's bug database.

Information Source Description
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Customer Service

http://www.oracle.com/support/
cus_serv/index.html

This site provides resources to make your interactions 
with Oracle as easy as possible. Among the things you 
can do are:

■ Learn what is a CPU Support Identification (CSI) 
number

■ Update your technical contact information

■ Find out whom to contact for invoice and collection 
issues

■ Request product update shipments

■ Access a glossary of Oracle Support Services terms

U.S. Customer Visit Program

http://www.oracle.com/support/
cus_serv/cus_visit.html

This U.S.-based program has been established to help 
our customers understand and obtain maximum benefit 
from the support services they have purchased.

The visit typically offers a customized orientation 
presentation, a comprehensive overview and 
demonstration of Oracle’s electronic services, and 
helpful tips on working more effectively with Oracle 
Support Services.

Support Web Center Library

http://www.oracle.com/support/
library/index.html

This site contains articles, guides, and other 
documentation to help you leverage the wealth of 
knowledge and reference material that Oracle Support 
Services produces.

Information Source Description
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Preface

This guide provides introductory information for the Pro*C/C++ precompiler 
running on Microsoft Windows operating systems. Specific topics discussed in this 
preface are:

■ Prerequisites

■ Intended Audience

■ How This Guide Is Organized

■ Conventions

■ Documentation Library

■ Related Documents
xvii



Prerequisites
This guide assumes that you are familiar with:

■ Commands for deleting and copying files and the concepts of the search path, 
subdirectories, and path names.

■ Microsoft Windows NT or Windows 95/98 operating system.

■ Microsoft Visual C++ version 5.0 or higher.

Intended Audience
This guide is necessary for anyone who wants to use the Pro*C/C++ precompiler 
on Microsoft Windows.

How This Guide Is Organized
This guide is organized as follows:

Chapter 1, "Introducing Pro*C/C++"
Describes Pro*C/C++, the Oracle programmatic interface for the C and C++ 
languages running on Microsoft Windows NT and Windows 95/98 operating 
systems.

Chapter 2, "Using Pro*C/C++"
Explains how to create and precompile a project. Also describes the Pro*C/C++ 
graphical user interface, from which you execute commands with Windows 
menus and icons or with keyboard equivalents, and using Pro*C/C++ at the 
command line.

Chapter 3, "Sample Programs"
Describes how to build Oracle database applications with Pro*C/C++ using the 
sample programs that are included with this release, and provides an overview 
of how to build multi-threaded applications.

Chapter A, "Integrating Pro*C/C++ into Microsoft Visual C++"
Describes how to integrate Pro*C/C++ into the Microsoft Visual C++ integrated 
development environment.
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Conventions
The following conventions are used in this guide.

Convention Example Meaning

All uppercase plain SQL> ALTER DATABASE Indicates command names, SQL reserved 
words, and keywords. 

Italic Italic is used to indicate a variable:

filename

Indicates a value that you must provide. For 
example, if a command asks you to type 
filename, you enter the actual name of the file.

Italic is also used for emphasis in the text and 
to indicate the titles of other guides.

square brackets [ ] x:\[pathname]\oracle\home_name Encloses optional items. For example, when 
you create an OFA-compliant Oracle home 
directory, you can place an optional pathname 
before the \oracle pathname. 

Square brackets also indicate a function key, 
for example [Enter]. 

C:\> C:\ORACLE> Represents the Windows platforms command 
prompt of the current hard disk drive. Your 
prompt may differ and may, at times, reflect 
the subdirectory in which you are working. 
Referred to as the MS-DOS command prompt in 
this guide.

Backslash (\) before a 
directory name

\bin Indicates that the directory is a subdirectory of 
the root directory.
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oracle_home and oracle_
base

Go to the oracle_base\oracle_
home\bin directory.

In this Optimal Flexible Architecture 
(OFA)-compliant release, all subdirectories are 
no longer under a top level oracle_home 
directory. There is now a new top-level 
directory called oracle_base that by default 
is c:\oracle. The Oracle home directories 
are located directly under oracle_base.

If you install Oracle8i release 8.1.6 on a 
computer where there is no other Oracle 
software on the computer, the default settings 
for the first Oracle home directory is 
c:\oracle\ora81. If you run Oracle 
Universal Installer again and install release 
8.2.x, the second Oracle home directory is 
called \ora82.

All directory path examples in this guide 
follow OFA conventions. For more 
information on OFA, see Oracle8i 
Administrator’s Guide for Windows NT.

HOME_NAME OracleHOME_NAMETNSListener Represents the Oracle home name. The home 
name can be up to sixteen alphanumeric 
characters. The only special character allowed 
in the home name is the underscore.

HOMEID HOME0, HOME1, HOME2 Represents a unique registry subkey for each 
Oracle home directory in which you install 
products. A new HOMEID is created and 
incremented each time you install products to 
a different Oracle home directory on one 
machine. Each HOMEID contains its own 
configuration parameter settings for installed 
Oracle products.

Convention Example Meaning
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Documentation Library
This guide is part of a larger library of Oracle documentation. The Oracle 
documentation library consists of two types of documentation:
  

Symbols period  .

comma  ,

hyphen  -

semicolon  ;

colon  :

equal sign  =

backslash  \

single quote  ‘

double quote  “

parentheses ()

Symbols other than brackets and vertical bars 
must be entered in commands exactly as 
shown.

Documentation Type Describes...

Operating System-specific Installation, configuration, and use of Oracle products in a Windows NT 
or Windows 95/98 environment. Operating system-specific documents 
are occasionally referred to in the generic documentation set. These 
documents are easy to identify because they always mention their 
specific operating system in their title.

Generic Oracle database, Oracle networking, and Application Programming 
Interfaces information that is uniform across all operating system 
platforms. The majority of documents in your documentation set belong 
to this category. While reading through the generic documentation set, 
you are occasionally asked to refer to your platform (or operating 
system) documentation for procedures specific to the Windows NT or 
Windows 95/98 operating systems. 

To easily identify where these generic documentation references are 
described in your operating system documentation, see the index of this 
guide for the following entry:

generic documentation references

All generic documentation references described in this guide appear 
under this index entry.

Convention Example Meaning
xxi



Related Documents
For more information, see the following manuals.

■ Oracle8i Installation Guide for Windows NT

■ Oracle8i Release Notes for Windows NT

■ Oracle8i Administrator’s Guide for Windows NT

■ Oracle Enterprise Manager Administrator’s Guide

■ Net8 Administrator’s Guide

■ Oracle8i Parallel Server Concepts

■ Oracle Parallel Server Administrator’s Guide for Windows NT

■ Getting to Know Oracle8i

■ Oracle8i Concepts

■ Oracle8i Reference

■ Oracle8i Error Messages

■  Pro*C/C++ Precompiler Programmer’s Guide 
xxii



Introducing Pro*C
1

Introducing Pro*C/C++

This chapter describes Pro*C/C++, the Oracle programmatic interface for the C and 
C++ languages running on Window operating systems. Pro*C/C++ enables you to 
build Oracle database applications in a Win32 environment. Specific topics 
discussed are:

■ What is Pro*C/C++?

■ Features

■ Restrictions

■ Directory Structure

Note: See the Pro*C/C++ Precompiler Programmer’s Guide for 
additional information.
/C++ 1-1



What is Pro*C/C++?
What is Pro*C/C++?
Pro*C/C++ precompiler allows you to create applications that access your Oracle 
database whenever rapid development and compatibility with other systems are 
your priorities.

The Pro*C/C++ programming tool enables you to embed Structured Query 
Language (SQL) statements in a C or C++ program. The Pro*C/C++ precompiler 
translates these statements into standard Oracle runtime library calls, then 
generates a modified source program that you can compile, link, and run in the 
usual way.

Features
Pro*C/C++ supports the following features:

■ Remote access with Net8 or local access to Oracle databases 

■ Embedded PL/SQL blocks

■ Bundled database calls, which can provide better performance in client/server 
environments

■ Full ANSI compliance for embedded SQL programming

■ PL/SQL version 8.0 and host language arrays in PL/SQL procedures

■ Multi-threaded applications

■ Full ANSI C compliance

■ Microsoft Visual C++ support, version 6.0 for 32-bit applications

Restrictions
Pro*C/C++ release 8.1.6 does not support 16-bit code generation.

Note: Borland C++ is no longer supported.
1-2 Pro*C/C++ Precompiler Getting Started



Directory Structure
Directory Structure
Installing Oracle software creates a directory structure on your hard drive for the 
Oracle products. A main Oracle directory contains the Oracle subdirectories and 
files that are necessary to run Pro*C/C++. 

When you install Pro*C/C++, Oracle Universal Installer creates a directory called 
\precomp in the oracle_base\oracle_home directory. This subdirectory 
contains the Pro*C/C++ executable files, library files, and sample programs listed in 
Table 1–1, "precomp Directory Structure".

Table 1–1 precomp Directory Structure

Directory Name Contents

\admin Configuration files

\demo\proc Sample programs for Pro*C/C++

\demo\sql SQL scripts for sample programs

\doc\proc Readme files for Pro*C/C++

\help\proc Help files for Pro*C/C++

\lib\msvc Library files for Pro*C/C++

\mesg Message files

\misc\proc Miscellaneous files for Pro*C/C++

\public Header files

Note: The \precomp directory can contain files for other 
products, such as Pro*COBOL.
Introducing Pro*C/C++ 1-3



Directory Structure
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Using Pro*C
2

Using Pro*C/C++

This chapter explains how to create and precompile a project. It also describes the 
Pro*C/C++ graphical user interface, from which you execute commands with 
Windows menus and icons or with keyboard equivalents, and using Pro*C/C++ at 
the command line. Specific topics discussed are:

■ Using the Graphical User Interface

■ Creating and Precompiling a Pro*C/C++ Project

■ Using Pro*C/C++ at the Command Line

■ Header Files

■ Library Files

■ Building Multi-Threaded Applications

■ Precompiler Options

■ Using Pro*C/C++ with the Oracle XA Library

Note: See the Pro*C/C++ Precompiler Programmer’s Guide for 
additional information about Pro*C/C++.
/C++ 2-1



Using the Graphical User Interface
Using the Graphical User Interface
Before you follow the instructions for creating and precompiling a Pro*C/C++ 
project, you should familiarize yourself with the basic commands, dialog boxes, 
menus, and buttons of the Pro*C/C++ graphical user interface.

Starting Pro*C/C++ Graphical Interface
To start the graphical user interface, choose Start > Programs > Oracle  - HOME_
NAME > Application Development > Pro C_C++.

The Pro*C/C++ precompile environment contains five elements noted in the 
following illustration:

Title Bar
The title bar displays the name of the Pro*C/C++ project. If you have not assigned a 
name to the current project, the word “Untitled” appears instead.

Title Bar

Menu Bar

Toolbar

Information
Pane

Status Bar
2-2 Pro*C/C++ Precompiler Getting Started



Using the Graphical User Interface
Menu Bar
The menu bar contains the following menus:

Toolbar
The toolbar enables you to execute commands by clicking a button:

Menu Description

File Contains commands to create a new Pro*C/C++ project, open an existing 
Pro*C/C++ project, save the active Pro*C/C++ project under the same 
name or under a different name, specify a connect string to an Oracle 
database, precompile a Pro*C/C++ project, and exit the application.

Edit Contains commands to add files to a Pro*C/C++ project, delete files from 
a Pro*C/C++ project, and display or change precompiler options.

Preferences Contains commands to set the default file extension of output files.

Help Contains the About Pro*C/C++ command, which displays the version 
number of the application and copyright information.

Button Description

New Create a new Pro*C/C++ project

Open Open an existing Pro*C/C++ project

Save Save the active Pro*C/C++ project under the same name

Add Add files to a Pro*C/C++ project

Delete Delete files from a Pro*C/C++ project

Options Display or change precompiler options

Precompile Precompile a Pro*C/C++ project

New SaveOpen DeleteAdd Options Precompile
Using Pro*C/C++ 2-3



Using the Graphical User Interface
Information Pane
The information pane consists of four elements noted in the following illustration:

Element Description

Precompilation Status Bar Indicates whether the precompilation for a file was successful 
or unsuccessful.

Input File Shows the files of a Pro*C/C++ project to be precompiled.

Output File Shows the output files of a Pro*C/C++ project after 
precompilation.

Options Displays precompile options that are different from the default 
options.

Input File

Output File

Options

Precompilation
status bar
2-4 Pro*C/C++ Precompiler Getting Started



Creating and Precompiling a Pro*C/C++ Project
Look for one of the three status icons in the precompilation status bar after the 
precompile process is complete.

■ A green check indicates that the file precompiled successfully.

■ A yellow check indicates that the file precompiled successfully, but there are 
one or more warnings.

■ A red X indicates that the file did not precompile successfully.

Double clicking a status icon opens the Precompilation Status dialog box. This dialog 
box provides detailed information on the reason for a warning or failure.

Status Bar
The status bar at the bottom of the window displays information about the progress 
of a precompilation. The status bar also identifies the purpose of a toolbar button or 
menu command when you place the mouse pointer over the toolbar button or 
menu command.

Creating and Precompiling a Pro*C/C++ Project
This section describes the steps involved in creating and precompiling a Pro*C/C++ 
project. After starting the Pro*C/C++ application, perform the following steps:

■ Opening a Project

■ Setting the Default Extension of Output Files

■ Changing the Name of an Existing Input or Output File

■ Adding Files to the Project

■ Deleting Files from the Project

■ Setting the Precompiler Options

■ Specifying Database Connection Information

■ Precompiling a Pro*C/C++ Project

■ Checking the Results

■ Fixing Errors

■ Exiting Pro*C/C++
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Opening a Project
Pro*C/C++ opens only one project at a time. A project consists of one or more 
precompilable files. Project files have an extension of .pre.

■ To create a new project, choose File > New Project.

■ To open an existing project, choose File > Open Project.

Setting the Default Extension of Output Files
Use the Preferences menu to determine the default extension of the output files.

This setting only affects input files that you add later. An existing output file name 
will not change. However, you can change an existing output file name by 
double-clicking the output file and entering a new name.

■ If you select Default Output C File Name, the default extension of the output 
files is .c.

■ If you select Default Output C++ File Name, the default extension of the output 
files is .cpp.

■ If you deselect both Default Output C File Name and Default Output C++ File 
Name, the Output File dialog box appears when you add an output file.

■ Enter an output file name for the file selected. After you select or enter a file 
name, it appears in the Output File area of the information pane.

Changing the Name of an Existing Input or Output File

To change the name of an existing input or output file:
1. Double-click the file name in the Input File or Output File area of the 

information pane. The Input File or Output File dialog box appears.
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2. Replace the old file name with the new file name.

3. Click Open.

Adding Files to the Project

To add files to the project:
1. Choose Edit > Add. The Input File dialog box appears.
Using Pro*C/C++ 2-7



Creating and Precompiling a Pro*C/C++ Project
2. Select one or more .pc files. Use the Ctrl key and the mouse to select files that 
are not adjacent.

3. Click Open. The selected files appear in the information pane.

Deleting Files from the Project
If you need to, you can easily delete one or more files from the project.

To delete files from the project:
1. Highlight the file(s) in the information pane.

2. Choose Edit > Delete.

3. Click Yes.

Setting the Precompiler Options
The Precompiler options enable you to control how resources are used, how errors 
are reported, how input and output are formatted, and how cursors are managed.

To set the precompile options:
1. Select one or more files in the Input File list.

2. Choose Edit > Options. The Options dialog box appears.
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Default options are in effect for all newly added files. When you change an 
option’s default setting, a description of the change appears in the Option 
String edit field at the bottom of the Options dialog box and in the Options area 
of the information pane. For additional information on options, see 
"Precompiler Options" on page 2-16.
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3. To change the format of the output list file that the precompiler writes to disk, 
click the Listing / Errors button. The Listing/Errors dialog box appears.

The settings include the type of error information generated and the name of 
the list file.

4. After you set the options in the Options dialog box, click OK.

Specifying Database Connection Information
If you selected semantics or full for the SQL Check option in the Options dialog box, 
you may need to specify database connection information to the Oracle database. 
You do not need to connect to the Oracle database if every table referenced in a data 
manipulation statement or PL/SQL block is defined in a DECLARE TABLE 
statement.
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To specify database connection information:
1. Choose File > Connect. The Connect dialog box appears.

2. Use this dialog box to specify database connection information prior to 
precompiling. No database connection is performed at this time. Only one set of 
database connection information can be specified for all files requiring semantic 
or full SQLCHECKing.

3. The Connect dialog box appears automatically at precompile time if you have 
not previously responded. Enter the user name, the password, and the network 
service name (database alias). The network service name is not required for a 
local database.

4. If you want to save the connection information between Pro*C/C++ sessions, 
select the Save Connect String to Disk check box. If you do not select the check 
box, you must enter this information each time you precompile.

5. Click OK.

Precompiling a Pro*C/C++ Project
You can precompile any number of files in the Input File list.

To precompile:
1. Select one or more files in the Input File list. You can use the Ctrl button to 

highlight files that are not adjacent to each other (for example, the first and 
third files in a list).

2. Choose File > Precompile.
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When precompiling is completed, the message in the dialog box indicates 
“Precompiling Finished!”, and the Cancel button changes to OK.

3. Click OK.

Checking the Results
Precompiling can result in success, success with warning(s), or failure. When 
precompiling is finished, check the precompilation status bar.

■ A green check indicates that the file compiled successfully.

■ A yellow check indicates that the file compiled successfully, but there are one or 
more warnings.

■ A red X indicates that the file did not compile successfully.

Fixing Errors
If you see a yellow check or a red X, double-click the icon in status bar. The 
Precompilation Status dialog box appears. This dialog box lists warning messages or 
reasons why the precompilation failed. For example:

Note: Although Cancel does not interrupt the precompile for a file 
already in process, it does halt the precompile chain for remaining 
files.
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Switch to your development environment to fix the problem(s). After you correct 
the errors, precompile again.

Exiting Pro*C/C++
To exit Pro*C/C++, choose File > Exit. If your project changed in any way, you are 
prompted to save it.

Using Pro*C/C++ at the Command Line
To precompile a file at the command line, enter the following command:

C:\> proc iname=filename.pc

where filename.pc is the name of the file. If the file is not in your current 
working directory, include the file’s full path after the INAME argument.

Pro*C/C++ generates filename.c, which can be compiled by your C compiler.

Note: If you receive a PCC-S-02014 error (syntax error at line num, 
column colnam, file name), do the following:

■ Copy the batch files mod_incl.bat and add_newl.bat from 
the oracle_base\oracle_home\precomp\misc\proc 
directory to the directory that contains the problematic 
INCLUDE file.

■ Run mod_incl.bat.

Suggestion: If you want to keep an original file, as well as a 
version of the file with your changes, choose the Save As 
command. The Save command overwrites the previous version.
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Header Files
The oracle_base\oracle_home\precomp\public directory contains the 
Pro*C/C++ header files.

See Also: See the Pro*C/C++ Precompiler Programmer’s Guide for 
more information about oraca.h, sqlca.h, and sqlda.h.

Header File Description

oraca.h Contains the Oracle Communications Area (ORACA), which helps you to diagnose 
runtime errors and to monitor your program’s use of various Oracle8 resources.

sql2oci.h Contains SQLLIB functions that enable the Oracle Call Interface (OCI) environment 
handle and OCI service context to be obtained in a Pro*C/C++ application.

sqlapr.h Contains ANSI prototypes for externalized functions that can be used in conjunction 
with OCI.

sqlca.h Contains the SQL Communications Area (SQLCA), which helps you to diagnose runtime 
errors. The SQLCA is updated after every executable SQL statement.

sqlcpr.h Contains platform-specific ANSI prototypes for SQLLIB functions that are generated by 
Pro*C/C++. By default, Pro*C/C++ does not support full-function prototyping of SQL 
programming calls. If you need this feature, include sqlcpr.h before any EXEC SQL 
statements in your application source file.

sqlda.h Contains the SQL Descriptor Area (SQLDA), which is a data structure required for 
programs that use dynamic SQL Method 4.

sqlkpr.h Contains K&R prototypes for externalized functions that can be used in conjunction with 
OCI.

sqlproto.h The sqlproto.h header file was obsoleted in Pro*C/C++ release 8.0.3. Use sqlcpr.h 
instead of sqlproto.h. However, applications that were built using sqlproto.h can 
be created without modification: a dummy sqlproto.h file that includes sqlcpr.h 
has been provided in the oracle_base\oracle_home\precomp\public directory.
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Library Files
The oracle_base\oracle_home\precomp\lib\msvc directory contains the 
library file that you use when linking Pro*C/C++ applications. The library file is 
called orasql8.lib.

Pro*C/C++ application program interface (API) calls are implemented in DLL files 
provided with your Pro*C/C++ software. To use the DLLs, you must link your 
application with the import libraries (.lib files) that correspond to the Pro*C/C++ 
DLLs. Also, you must ensure that the DLL files are installed on the computer that is 
running your Pro*C/C++ application.

Microsoft provides you with three libraries: libc.lib, libcmt.lib, and 
msvcrt.lib. The Oracle DLLs use the msvcrt.lib runtime library. You must 
link with msvcrt.lib rather than the other two Microsoft libraries.

Building Multi-Threaded Applications
Build multi-threaded applications if you are planning to perform concurrent 
database operations.

Windows NT and Windows 95/98 schedule and allocate threads belonging to 
processes. A thread is a path of a program’s execution. It consists of a kernel stack, 
the state of the CPU registers, a thread environment block, and a users stack. Each 
thread shares the resources of a process. Multi-threaded applications use the 
resources of a process to coordinate the activities of individual threads.

When building a multi-threaded application, make sure that your C/C++ code is 
reentrant. This means that access to static or global data must be restricted to one 
thread at a time. If you mix multi-threaded and non-reentrant functions, one thread 
can modify information that is required by another thread.

The Pro*C/C++ precompiler automatically creates variables on the local stack of the 
thread. This ensures that each thread using the Pro*C/C++ function has access to a 
unique set of variables and is reentrant.

See Also: See the Pro*C/C++ Precompiler Programmer’s Guide for 
additional information on how to write multi-threaded applications 
with Pro*C/C++.
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Precompiler Options
This section highlights issues related to Pro*C/C++ for Windows platforms. 

Configuration File
A configuration file is a text file that contains precompiler options.

For this release, the system configuration file is called pcscfg.cfg. This file is 
located in the oracle_base\oracle_home\precomp\admin directory.

CODE
The CODE option has a default setting of ANSI_C. Pro*C/C++ for other operating 
systems may have a default setting of KR_C.

DBMS
DBMS=V6_CHAR is not supported when using CHAR_MAP=VARCHAR2. 
Instead, use DBMS=V7.

INCLUDE
For the Pro*C/C++ graphical user interface, use the Include Directories field of the 
Options dialog box to enter INCLUDE path directories. If you want to enter more 
than one path, separate each path with a semicolon, but do not insert a space after 
the semicolon. This causes a separate “INCLUDE=” string to appear in front of each 
directory.

For sample programs that precompile with PARSE=PARTIAL or PARSE=FULL, an 
include path of c:\program files\devstudio\vc\include has been added. 
If Microsoft Visual C++ has been installed in a different location, modify the Include 
Directories field accordingly for the sample programs to precompile correctly.

PARSE
The PARSE option has a default setting of NONE. Pro*C/C++ for other operating 
systems may have a default setting of FULL.

See Also: See the "Precompiler Options" chapter of the Pro*C/C++ 
Precompiler Programmer’s Guide for more information on the 
precompiler options.
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Using Pro*C/C++ with the Oracle XA Library
The XA Application Program Interface (API) is typically used to enable an Oracle 
database to interact with a transaction processing (TP) monitor, such as:

■ BEA Tuxedo 

■ IBM Transarc Encina

■ IBM CICS

You can also use TP monitor statements in your client programs. The use of the XA 
API is also supported from both Pro*C/C++ and OCI. 

The Oracle XA Library is automatically installed as part of Oracle8i Enterprise 
Edition. The following components are created in your Oracle home directory:
  

Compiling and Linking a Pro*C/C++ Program with XA
To compile and link a Pro*C/C++ program with XA:

1. Precompile filename.pc using Pro*C/C++ to generate filename.c.

2. Compile filename.c, making sure to include oracle_base\oracle_
home\rdbms\xa in your path.

3. Link filename.obj with the following libraries:

4. Run filename.exe.

Component Location

oraxa8.lib oracle_base\oracle_home\rdbms\xa

xa.h oracle_base\oracle_home\rdbms\xa

Library Location

oraxa8.lib oracle_base\oracle_home\rdbms\xa

oci.lib oracle_base\oracle_home\oci\lib\msvc

orasql8.lib oracle_base\oracle_home\precomp\lib\msvc
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XA Dynamic Registration
Oracle supports the use of XA dynamic registration. XA dynamic registration 
improves the performance of applications that interface with XA-compliant TP 
monitors.

For TP monitors to use XA dynamic registration with an Oracle database on 
Windows NT, you must add either an environmental variable or a registry variable 
to the Windows NT computer on which your TP monitor is running. See either of 
the following sections for instructions:

■ Adding an Environmental Variable for the Current Session

■ Adding a Registry Variable for All Sessions

Adding an Environmental Variable for the Current Session
Adding an environmental variable at the MS-DOS command prompt affects only 
the current MS-DOS session.

To add an environmental variable for the current session:

1. Go to the computer where your TP monitor is installed.

2. Enter the following at the MS-DOS command prompt:

C:\> set ORA_XA_REG_DLL = vendor.dll

where vendor.dll is the TP monitor DLL provided by your vendor.

Adding a Registry Variable for All Sessions
Adding a registry variable affects all sessions on your Windows NT computer. This 
is useful for computers where only one TP monitor is running. 

To add a registry variable for all sessions:

1. Go to the computer where your TP monitor is installed.

2. Enter the following at the MS-DOS command prompt:

C:\> regedit

The Registry Editor window appears.

3. Go to HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE. 

4. Choose the Add Value option in the Edit menu.

The Add Value dialog box appears.
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5. Enter ORA_XA_REG_DLL in the Value Name field.

6. Select REG_EXPAND_SZ from the Data Type drop-down list box.

7. Click OK.

The String Editor dialog box appears.

8. Enter vendor.dll in the String field, where vendor.dll is the TP monitor 
DLL provided by your vendor.

9. Click OK.

The Registry Editor adds the parameter. 

10. Choose Exit from the Registry menu.

The registry exits.

XA and TP Monitor Information
Refer to the following for more information about XA and TP monitors:

■ Distributed TP: The XA Specification published by X/Open (now part of 
OpenGroup). See the web site at:

http://www.opengroup.org/public/pubs/catalog/full_lst.htm

■ Transaction Processing XPG4 X/Open CAE Specification XO/CAE/91/300 or C193 
2/92

■ X/Open Company, Ltd., 1010 El Camino Real, Suite 380, Menlo Park, CA 
94025, U.S.A.

■ Your specific TP monitor documentation

See Also: For more information about the Oracle XA Library and 
using XA dynamic registration, see Oracle8i Application Developer’s 
Guide - Fundamentals.
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Sample Programs

This chapter describes how to build Oracle database applications with Pro*C/C++ 
using the sample programs that are included with this release. Specific topics 
discussed are:

■ Sample Program Descriptions

■ Building the Demonstration Tables

■ Building the Sample Programs
rams 3-1
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Sample Program Descriptions
When you install Pro*C/C++, Oracle Installer copies a set of Pro*C/C++ sample 
programs to the oracle_base\oracle_home\precomp\demo\proc directory. 
These sample programs are listed in Table 3–1, "Sample Programs". The SQL scripts 
are located in the oracle_base\oracle_home\precomp\demo\sql directory.

Oracle recommends that you build and run these sample programs to verify that 
Pro*C/C++ has been installed successfully and operates correctly. You can delete 
the programs after you use them.

When built, the sample programs that Oracle provides in Pro*C/C++ produce .exe 
executables. For some sample programs, you must run the SQL scripts in the 
sample directory before you precompile and run the sample program. The SQL 
scripts set up the correct tables and data so that the sample programs run correctly.

Table 3–1 Sample Programs

Sample 
Program Source Files

Pro*C/C++ GUI 
Project File

MSVC Compiler
Project File Notes

ANSIDYN1 ansidyn1.pc ansidyn1.pre ansidyn1.dsp

ANSIDYN2 ansidyn2.pc ansidyn2.pre ansidyn2.dsp

COLDEMO1 coldemo1.h 
coldemo1.pc 
coldemo1.sql 
coldemo1.typ

coldemo1.pre coldemo1.dsp Run coldemo1.sql and the 
Object Type Translator before 
building coldemo1.

CPPDEMO1 cppdemo1.pc cppdemo1.pre cppdemo1.dsp

CPPDEMO2 cppdemo2.pc 
empclass.pc 
cppdemo2.sql 
empclass.h

cppdemo2.pre cppdemo2.dsp Run cppdemo2.sql before 
building cppdemo2.

CPPDEMO3 cppdemo3.pc cppdemo3.pre cppdemo3.dsp

CVDEMO cv_demo.pc
cv_demo.sql

cv_demo.pre cv_demo.dsp Run cv_demo.sql before 
building cv_demo.

EMPCLASS cppdemo2.pc 
empclass.pc 
cppdemo2.sql 
empclass.h

empclass.pre empclass.dsp Run cppdemo2.sql before 
building empclass.
3-2 Pro*C/C++ Precompiler Getting Started



Sample Program Descriptions
LOBDEMO1 lobdemo1.h 
lobdemo1.pc 
lobdemo1.sql

lobdemo1.pre lobdemo1.dsp Run lobdemo1.sql before 
building lobdemo1.

MLTTHRD1 mltthrd1.pc 
mltthrd1.sql

mltthrd1.pre mltthrd1.dsp Run mltthrd1.sql before 
building mltthrd1.

NAVDEMO1 navdemo1.h 
navdemo1.pc 
navdemo1.sql 
navdemo1.typ

navdemo1.pre navdemo1.dsp Run navdemo1.sql and the 
Object Type Translator before 
building navdemo1.

OBJDEMO1 objdemo1.h 
objdemo1.pc 
objdemo1.sql 
objdemo1.typ

objdemo1.pre objdemo1.dsp Run objdemo1.sql and the 
Object Type Translator before 
building objdemo1.

ORACA oraca.pc 
oracatst.sql

oraca.pre oraca.dsp Run oracatst.sql before 
building oraca.

PLSSAM plssam.pc plssam.pre plssam.dsp

SAMPLE sample.pc sample.pre sample.dsp

SAMPLE1 sample1.pc sample1.pre sample1.dsp

SAMPLE2 sample2.pc sample2.pre sample2.dsp

SAMPLE3 sample3.pc sample3.pre sample3.dsp

SAMPLE4 sample4.pc sample4.pre sample4.dsp

SAMPLE5 sample5.pc 
exampbld.sql 
examplod.sql

sample5.pre sample5.dsp Run exampbld.sql, then run 
examplod.sql, before 
building sample5.

SAMPLE6 sample6.pc sample6.pre sample6.dsp

SAMPLE7 sample7.pc sample7.pre sample7.dsp

SAMPLE8 sample8.pc sample8.pre sample8.dsp

SAMPLE9 sample9.pc 
calldemo.sql

sample9.pre sample9.dsp Run calldemo.sql before 
building sample9.

SAMPLE10 sample10.pc sample10.pre sample10.dsp

SAMPLE11 sample11.pc 
sample11.sql

sample11.pre sample11.dsp Run sample11.sql before 
building sample11.

SAMPLE12 sample12.pc sample12.pre sample12.dsp

Sample 
Program Source Files

Pro*C/C++ GUI 
Project File

MSVC Compiler
Project File Notes
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The following subsections describe the functionality of the sample programs.

ANSIDYN1
Demonstrates using ANSI dynamic SQL to process SQL statements that are not 
known until runtime. This program is intended to demonstrate the simplest 
(though not the most efficient) approach to using ANSI dynamic SQL.

ANSIDYN2
Demonstrates using ANSI dynamic SQL to process SQL statements that are not 
known until runtime. This program uses the Oracle extensions for batch processing 
and reference semantics.

COLDEMO1
Fetches census information for California counties. This program demonstrates 
various ways to navigate through collection-typed database columns.

CPPDEMO1
Prompts the user for an employee number, then queries the EMP table for the 
employee’s name, salary, and commission. This program uses indicator variables (in 
an indicator struct) to determine whether the commission is NULL.

CPPDEMO2
Retrieves the names of all employees in a given department from the EMP table 
(dynamic SQL Method 3).

CPPDEMO3
Finds all salespeople and prints their names and total earnings (including 
commissions). This program is an example of C++ inheritance.

CVDEMO
Declares and opens a ref cursor.

SQLVCP sqlvcp.pc sqlvcp.pre sqlvcp.dsp

WINSAM resource.h 
winsam.h 
winsam.ico 
winsam.pc 
winsam.rc

winsam.pre winsam.dsp

Sample 
Program Source Files

Pro*C/C++ GUI 
Project File

MSVC Compiler
Project File Notes
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EMPCLASS
The EMPCLASS and CPPDEMO2 files were written to provide an example of how 
to write Pro*C/C++ programs within a C++ framework. EMPCLASS encapsulates a 
specific query on the emp table and is implemented using a cursor variable. 
EMPCLASS instantiates an instance of that query and provides cursor variable 
functionality (that is: open, fetch, close) through C++ member functions that belong 
to the emp class. The empclass.pc file is NOT a standalone demo program. It was 
written to be used by the cppdemo2 demo program. To use the emp class, you have 
to write a driver (cppdemo2.pc) which declares an instance of the emp class and 
issues calls to the member functions of that class.

LOBDEMO1
Fetches and adds crime records to the database based on the person’s Social 
Security number. This program demonstrates the mechanisms for accessing and 
storing large objects (LOBs) to tables and manipulating LOBs through the stored 
procedures available through the DBMS_LOB package.

MLTTHRD1
Shows how to use threading in conjunction with precompilers. The program creates 
as many sessions as there are threads. See"Building Multi-Threaded Applications"  
on page 2-15.

NAVDEMO1
Demonstrates navigational access to objects in the object cache.

OBJDEMO1
Demonstrates the use of objects. This program manipulates the object types person 
and address.

ORACA
Demonstrates how to use ORACA to determine various performance parameters at 
runtime.

PLSSAM
Demonstrates the use of embedded PL/SQL blocks. This program prompts you for 
an employee name that already resides in a database. It then executes a PL/SQL 
block, which returns the results of four SELECT statements.

SAMPLE
Adds new employee records to the personnel database and checks database 
integrity. The employee numbers in the database are automatically selected using 
the current maximum employee number +10.
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SAMPLE1
Logs on to an Oracle database, prompts the user for an employee number, queries 
the database for the employee’s name, salary, and commission, and displays the 
result. The program continues until the user enters 0 as the employee number.

SAMPLE2
Logs on to an Oracle database, declares and opens a cursor, fetches the names, 
salaries, and commissions of all salespeople, displays the results, and closes the 
cursor.

SAMPLE3
Logs on to an Oracle database, declares and opens a cursor, fetches in batches using 
arrays, and prints the results using the print_rows() function.

SAMPLE4
Demonstrates the use of type equivalencing using the LONG VARRAW external 
datatype.

SAMPLE5
Prompts the user for an account number and a debit amount. The program verifies 
that the account number is valid and that there are sufficient funds to cover the 
withdrawal before it debits the account. This program shows the use of embedded 
SQL.

SAMPLE6
Creates a table, inserts a row, commits the insert, and drops the table (dynamic SQL 
Method 1).

SAMPLE7
Inserts two rows into the EMP table and deletes them (dynamic SQL Method 2).

SAMPLE8
Retrieves the names of all employees in a given department from the EMP table 
(dynamic SQL Method 3).

SAMPLE9
Connects to an Oracle database using the SCOTT/TIGER account. The program 
declares several host arrays and calls a PL/SQL stored procedure (GET_
EMPLOYEES in the CALLDEMO package). The PL/SQL procedure returns up to 
ASIZE values. The program keeps calling GET_EMPLOYEES, getting ASIZE arrays 
each time, and printing the values, until all rows have been retrieved.
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SAMPLE10
Connects to an Oracle database using your user name and password and prompts 
for a SQL statement. You can enter any legal SQL statement, but you must use 
regular SQL syntax, not embedded SQL. Your statement is processed. If the 
statement is a query, the rows fetched are displayed (dynamic SQL Method 4).

SAMPLE11
Fetches from the EMP table, using a cursor variable. The cursor is opened in the 
stored PL/SQL procedure open_cur, in the EMP_DEMO_PKG package.

SAMPLE12
Demonstrates how to do array fetches using dynamic SQL Method 4.

SQLVCP
Demonstrates how you can use the sqlvcp() function to determine the actual size of a 
VARCHAR struct. The size is then used as an offset to increment a pointer that steps 
through an array of VARCHARs.

This program also demonstrates how to use the SQLStmtGetText() function to 
retrieve the text of the last SQL statement that was executed.

WINSAM
Adds new employee records to the personnel database and checks database 
integrity. You can enter as many employee names as you want and perform the SQL 
commands by selecting the appropriate buttons in the Employee Record dialog box. 
This is a GUI version of the sample program.
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Building the Demonstration Tables
To run the sample programs, you must have a database account with the user name 
SCOTT and the password TIGER. Also, you must have a database with the sample 
tables EMP and DEPT. This account is included in the starter database for your 
Oracle8i server. If the account does not exist on your database, create the account 
before running the sample programs.

See Oracle8i Administrator’s Guide for Windows NT for more information. If your 
database does not contain EMP and DEPT tables, you can use the demobld.sql 
script to create them.

To build the sample tables:
1. Start SQL*Plus

2. Connect as user name SCOTT with the password TIGER.

3. Run the demobld.sql script:

SQL> @ORACLE_BASE\ORACLE_HOME\SQLPLUS\DEMO\DEMOBLD.SQL;
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Building the Sample Programs
Microsoft Visual C++ 6.0 project files have an extension of .dsp. The .dsp files in 
the oracle_base\oracle_home\precomp\demo\proc directory guide and 
control the steps necessary to precompile, compile, and link the sample programs.

Pro*C/C++, SQL*Plus, and the Object Type Translator have been integrated into the 
Microsoft Visual C++ sample project files. You do not have to run Pro*C/C++, 
SQL*Plus, and the Object Type Translator separately before compilation. See 
Appendix A, "Integrating Pro*C/C++ into Microsoft Visual C++" for more 
information.

To build a sample program:
1. Open a Visual C++ project file, such as sample1.dsp.

2. Check the paths in the project file to ensure that they correspond to the 
configuration of your system. If they do not, change the paths accordingly. Your 
system may produce error messages if the paths to all components are not 
correct. See "Setting the Precompiler Options" on page 2-8 and "Setting the Path 
for the Sample .pre Files" on page 3-10.

3. Choose Build > Rebuild All. Visual C++ creates the executable.

See Also: For more information on OTT, see the Pro*C/C++ 
Precompiler Programmer’s Guide.

Note: All of the sample programs were created with 
c:\oracle\ora81 as the default drive.
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Setting the Path for the Sample .pre Files
By default the sample .pre files search for their corresponding .pc files in the 
c:\oracle\ora81 directory where c:\ is the drive that you are using, and 
oracle\ora81 represents the location of the Oracle home. If the Oracle base and 
Oracle home directories are different on your computer, you must change the 
directory path to the correct path. 

To change the directory path for a sample .pre file: 

1. In Pro*C/C++, open the .pre file. 

2. Double-click the file name in the Input File area to display the Input File dialog 
box. 

3. Change the directory path to the correct path. 

4. Click Open. 
3-10 Pro*C/C++ Precompiler Getting Started



Integrating Pro*C/C++ into Microsoft Visua
A

Integrating Pro*C/C++ into Microsoft Visual

C++

This appendix describes how to integrate Pro*C/C++ into the Microsoft Visual C++ 
integrated development environment. Specific topics discussed are:

■ Integrating Pro*C/C++ within Microsoft Visual C++ Projects

■ Adding Pro*C/C++ to the Tools Menu
l C++ A-1
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Integrating Pro*C/C++ within Microsoft Visual C++ Projects
This section describes how to fully integrate Pro*C/C++ within Microsoft Visual 
C++ projects.

All the precompiler errors and warnings are displayed in the output box where 
Microsoft Visual C++ displays compiler and linker messages. You do not have to 
precompile a file separately from the Microsoft Visual C++ build environment. 
More importantly, Microsoft Visual C++ maintains the dependencies between .c 
and .pc files. Microsoft Visual C++ maintains the dependency and precompile files, 
if needed. 

All of the procedures in this section are performed within Microsoft Visual C++.

Specifying the Location of the Pro*C/C++ Executable
For Microsoft Visual C++ to run Pro*C/C++, it needs to know the location of the 
Pro*C/C++ executable. If Microsoft Visual C++ was installed before any Oracle 8.1 
products were installed, then you must add the directory path.

To specify the location of the Pro*C/C++ executable:
1. Choose Options from the Tools menu. The Options dialog box appears.

2. Click the Directories tab.
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3. Select Executable files from the Show directories for list box.

4. Scroll to the bottom of the Directories box and click the dotted rectangle.

5. Enter the oracle_base\oracle_home\bin directory. For example:

c:\oracle\ora81\bin

6. Click OK.

Specifying the Location of the Pro*C/C++ Header Files

To specify the location of the Pro*C/C++ header files:
1. Choose Options from the Tools menu. The Options dialog box appears.

2. Click the Directories tab.

3. Select Include Files from the Show directories for list box.

4. Scroll to the bottom of the Directories box and click the dotted rectangle.

5. Enter the oracle_base\oracle_home\precomp\public directory. For 
example:

c:\oracle\ora81\precomp\public

6. Click OK.
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Adding .pc Files to a Project
After you create a project, you need to add the .pc file(s).

To add a .pc file to a project:
1. Choose Add To Project from the Project menu, and then choose Files. The Insert 

Files into Project dialog box appears.

2. Select All Files from the Files of type list box.

3. Select the .pc file.

4. Click OK.

Adding References to .c Files to a Project
For each .PC file, you need to add a reference to the .C file that will result from 
precompiling.

To add a reference to a .c file to a project:
1. Choose Add To Project from the Project menu, and then choose Files. The Insert 

Files into Project dialog box appears.

2. Type the name of the .c file in the File Name box.
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3. Click OK. Because the .c file has not been created yet, Microsoft Visual C++ 
displays the following message: “The specified file does not exist. Do you want 
to add a reference to the project anyway?”

4. Click Yes.

Adding the Pro*C/C++ Library to a Project
Pro*C/C++ applications must link with the library file orasql8.lib.

To add the Pro*C/C++ library to a project:
1. Choose Add To Project from the Project menu, and then choose Files.

The Insert Files into Project dialog box appears.

2. Select All Files from the Files of type list box.

3. Select orasql8.lib from the oracle_base\oracle_
home\precomp\lib\msvc directory.

4. Click OK.
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Specifying Custom Build Options

To specify custom build options:
1. In FileView, right-click a .pc file and choose Settings. The Project Settings dialog 

box appears with the Custom Build tab displayed.

2. In the Build command(s) box, enter the following on one line:

$(ProjDir)\..\..\..\..\bin\proc $(ProjDir)\$(InputName).pc
include=$(ProjDir)\..\..\..\public include="$(MSDEVDIR)\..\vc\include"

$(ProjDir) and $MSDEVDIR are macros for custom build commands in 
Microsoft Visual C++. See the Microsoft Visual C++ documentation for more 
information.

3. In the Output file(s) box, enter one of the following:

If You Are Generating... Enter...

.C files $(ProjDir)\$(InputName).c
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When the project is built, Microsoft Visual C++ will check the date of the output 
files to determine whether they need to be rebuilt for any new modifications 
made to the source code. See the Microsoft Visual C++ documentation for more 
information.

4. Click OK.

Adding Pro*C/C++ to the Tools Menu
You can include Pro*C/C++ as a choice in the Tools menu of Microsoft Visual C++.

To add Pro*C/C++ to the Tools menu:
1. From within Microsoft Visual C++, choose Customize from the Tools menu. The 

Customize dialog box appears.

2. Click the Tools tab.

3. Scroll to the bottom of the Menu contents box and click the dotted rectangle.

4. Enter the following text:

Pro*C/C++

.CPP files $(ProjDir)\$(InputName).cpp

If You Are Generating... Enter...
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5. In the Command box, type the path and file name of the graphical Pro*C/C++ 
executable, or use the Browse button to the right of the box to select the file 
name. For example:

c:\oracle\ora81\bin\procui.exe

6. In the Arguments box, enter the following text.

$(TargetName)

When you choose Pro*C/C++ 8.1 from the Tools menu, Microsoft Visual C++ 
uses the $(TargetName) argument to pass the name of the current development 
project to Pro*C/C++. Pro*C/C++ then opens a precompile project with the 
same name as the opened project, but with a .PRE extension in the project 
directory.

7. In the Initial directory box, enter the following text:

$(WkspDir)

The Customize dialog box should now look like the following graphic (although 
the Oracle home directory may be different on your computer).

8. Click Close. Microsoft Visual C++ adds Pro*C/C++ to the Tools menu.
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